Issues with sending emails (including alerts)
Incident Report for Redash
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 19, 2019 - 23:00 UTC
Monitoring
We switched to a new email provider and monitoring the issue.
Posted 7 months ago. Mar 19, 2019 - 20:08 UTC
Identified
Redash has been a victim of spam abuse and our domain is currently rate limited for sending emails. We're working to resolve this.
Posted 7 months ago. Mar 19, 2019 - 19:08 UTC
This incident affected: External Dependencies (mailgun Outbound Delivery).